Application unavailable

Incident Report for Booqable

Resolved

This incident has been resolved.
Posted Apr 12, 2024 - 18:38 CEST

Investigating

We are currently investigating this issue.
Posted Apr 12, 2024 - 17:29 CEST
This incident affected: Web application.