Experiencing Issues with Payments
Incident Report for Booqable
Resolved
This incident has been resolved.
Posted over 1 year ago. Nov 15, 2017 - 00:27 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted over 1 year ago. Nov 14, 2017 - 21:11 CET
Identified
There were elevated declines for charges on some US-issued cards. Failed charges can safely be retried.
Posted over 1 year ago. Nov 14, 2017 - 21:11 CET
Investigating
Our payment provider Stripe is seeing increased decline rates and latency for a portion of US-issued cards. They're investigating and we will post updates here.
Posted over 1 year ago. Nov 14, 2017 - 20:21 CET