A fix has been implemented and we are monitoring the results.
Posted Apr 18, 2025 - 12:46 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 18, 2025 - 10:55 CEST
Investigating
We are currently investigating an issue affecting document downloads on our platform. Some users may experience failures or delays when attempting to download documents. All other core services remain operational.
Our engineering team is actively working to identify the root cause and implement a fix as soon as possible.
We appreciate your patience and apologize for the inconvenience.